Belajar Mikrotik: Static Routing di RouterOS versi 7

Belajar Mikrotik: Static Routing di RouterOS versi 7

Static Routing di RouterOS versi 7


Router mempunyai fungsi routing yang bisa digunakan untuk menghubungkan jaringan yang berbeda segment network. Mikrotik mulai mengeluarkan versi routerOS terbaru yaitu versi 7 (hingga artikel ini ditulis, RouterOS sudah sampai pada tahap versi 7.1beta2 (Development). Yuk kita bahas secara detail apakah terdapat perbedaan static routing pada versi 7 dengan versi sebelumnya. 

RouterOS atau sering disebut ROS, adalah sistem operasi jaringan berbasis Linux. Sistem operasi ini digunakan pada perangkat Mikrotik. Selain itu juga bisa diinstall pada pada PC agar bisa berfungsi sebagai router dan beberapa fungsi jaringan lainnya seperti VPN, QOS, Firewall, dll.

Dalam perkembangannya, RouterOS menggunakan beberapa versi berdasarkan kernel yang digunakan. Terdapat RouterOS versi 3, versi 4, versi 5 yang menggunakan kernel linux versi 2.x.x. Saat ini yang masih sering digunakan adalah RouterOS versi 6 yang menggunakan kernel linux 3.3.5. Baru-baru ini Mikrotik mengeluarkan RouterOS versi 7 yang menggunakan kernel berbeda, yaitu kernel linux 5.6.3. Perubahan kernel pada routerOS ini menyebabkan munculnya struktur baru pada system operasi. Review mengenai RouterOS versi 7 bisa anda cek di artikel kami sebelumnya di sini.

Kali ini kami akan membahas mengenai static routing pada RouterOS versi 7. Kita coba cek apakah terdapat perbedaan dengan versi sebelumnya yaitu versi 6. Yuk kita bandingkan routing pada versi 6 dan versi 7. 

Topologi 1 
Untuk topologi pertama, kami menggunakan 2 router yang saling terhubung langsung. Router1 menggunakan routeros versi 7, dan Router2 menggunakan routeros versi 6.

 

Setelah IP terpasang pada kedua router, kita coba cek menu IP>Route apakah terdapat perbedaan pada kedua router. 

Berikut Table Routing pada Versi 6 

 

Berikut Table Routing pada Versi 7

 

Agar Client di Router1 dan Client di Router2 bisa saling komunikasi, maka kita harus menambahkan static routing pada kedua router tersebut. Penambahan static route bisa menggunakan menu IP>Route.

Konfigurasi static route pada Router2 (v6) adalah sebagai berikut

 

Konfigurasi static route pada Router1 (v7) adalah sebagai berikut

 

Topologi 2 
Untuk topologi kedua, kami menggunakan VPN yaitu PPTP untuk interkoneksi antara Router1 dan Router2 melalui jaringan internet. 

 

Penambahan static routing pada Router2 (v6) karena menggunakan VPN maka gateway yang digunakan adalah interface VPN (PPTP).

 

Penambahan static routing pada Router1 (v7) agak sedikit berbeda karena tidak terdapat pilihan interface. Anda harus menuliskan secara manual interface VPN yang digunakan (co:pptp-out1)

 

Atau bisa menggunakan opsi IP sekaligus interface yang digunakan. Contoh adalah sebagai berikut .

  

Kesimpulan 
Konfigurasi static routing tidak ada banyak perubahan pada versi 7. Hanya ada beberapa perubahan tampilan dan informasi seperti parameter "Immediate Gateway" untuk menginformasikan interface yang digunakan. Kita bisa mulai membiasakan menggunakan RouterOS versi 7 karena akan banyak fitur baru dan konfigurasi baru. Yang bahkan fitur baru tersebut belum ada di versi sebelumnya. 

LET'S ROUTING THE WORLD 

Artikel ini dibuat pada 6 November 2020


Sumber: http://mikrotik.co.id

Tutorial Mikrotik: [Mikrobits] Netinstall Dinara V3 Dan Ainos V3

Tutorial Mikrotik: [Mikrobits] Netinstall Dinara V3 Dan Ainos V3

[Mikrobits] Netinstall Dinara V3 Dan Ainos V3


Mikrobits Dinara dan Ainos adalah router mikrotik berbasis x86 dan tidak tersedia tombol reset untuk memulihkan konfigurasi ke kondisi awal. Metode yang bisa dilakukan adalah install ulang menggunakan "Netinstall". Langkah langkah untuk melakukan install ulang perangkat Mikrobits Dinara v3 dan Ainos v3 adalah sebagai berikut :  

Persiapan : 

  • Matikan Mikrobits Dinara v3/Ainos v3.
  • Siapkan kabel console untuk melakukan konfigurasi bios pada perangkat Mikrobits. Khusus untuk Mikrobits Dinara v3 dan Ainos v3, maka bisa menggunakan console Mikrobits Dinara. Console Mikrobits Dinara bisa Anda dapatkan pada halaman berikut: Console Dinara 
 
  • Hubungkan ujung kabel rj45 kabel console tersebut ke port console Mikrobits Dinara v3/Ainos v3.
  • Hubungkan ujung kabel db9 serial ke port serial di pc atau ke port serial di usb-to-serial converter (contoh ATEN UC 232A).
 
  • Untuk menggunakan kabel USB to Serial ATEN UC 232A, maka Anda juga perlu mendownload drivernya terlebih dahulu. Driver ATEN UC 232A bisa di download pada halaman berikut: Driver ATEN UC 232A.
  • Dalam melakukan konfigurasi BIOS, selain menggunakan kabel console, untuk Mikrobits Dinara v3/Ainos v3 di bekali dengan port VGA, sehingga dalam melakukan konfigurasi bios bisa juga menggunakan port VGA ini dan dihubungkan ke monitor, hubungkan juga keyboard ke Mikrobits Dinara v3/Ainos v3.
 
  • Hubungkan ethernet kabel dari PC yang memiliki netinstall ke "port 1" Mikrobits.
  • Jangan lupa untuk mencabut kabel sata yang terhubung dengan SSD/Harddisk.
Tools : 
  • Pastikan anda memiliki program netinstall di PC yang akan digunakan untuk menginstall ulang perangkat Mikrobits Dinara v3/Ainos v3 (direkomendasikan Netinstall versi 6.28).
  • Anda bisa download di Mikrotik Download Archive jika program Netinstall belum dimiliki.
  • Pastikan juga anda memiliki paket os mikrotik untuk Mikrobits, anda bisa download di https://mikrotik.com/download, gunakan OS terbaru dan berformat X86. 
  • Siapkan program hyperterminal atau putty kemudian konfigurasi port serial dengan setting : 
    • Serial Line = Sesuaikan dengan port yang digunakan, bisa di check pada menu "device manager" windows. Misal COM6
    • baud-rate = 115200
    • data-bits = 8
    • parity = none
    • stop-bits = 1
    • flow-control = hardware
Bios Setting : 
  • Setelah semua kabel ethernet dan juga console/VGA sudah terhubung, maka bisa hidupkan kembali perangkat Mikrobits Dinara v3/Ainos v3.
  • Akan muncul di hyper terminal/putty/monitor tampilan boot dari Mikrobits Dinara v3/Ainos v3.
  • Tekan tombol keyboard "del" untuk masuk ke setting bios dari Mikrobits Dinara v3/Ainos v3.
  • Setelah masuk bios pilih pada menu "Advanced", kemudian "CSM Configuration"
  • Pada konfigurasi "network" pilih "Legacy" mode.
  • Kemudian pada konfigurasi LAN, arahkan ke LAN1.
 
  • Lakukan konfigurasi Boot Priority, dan arahkan "Boot Option #1" ke pilihan "IBA GE Slot". (Jika parameter "IBA GE Slot" tidak tertampil, maka bisa lakukan Save & Exit setup kemudian reboot terlebih dahulu).
 
  • Tekan  tombol keyboard "esc" untuk keluar dari menu saat ini.
  • Setelah kembali ke menu utama pilih "Save & Exit Setup".
Langkah Install ulang dengan Netinstall : 
  • Jalankan software netinstall.exe versi 6.28 yang sebelumnya sudah didownload.
  • Klik tombol "net-booting" untuk mengkonfigurasi boot servernya.
  • Aktifkan opsi "Boot server enabled"
  • Isikan ip address di parameter "Client ip address" dengan ip address yang satu segmen dengan ip address di pc tetapi tidak sama dengan ip address di PC.
  • Klik tombol ok dan tunggu responnya.
  • Akan muncul item baru di netinstall dengan label : "mikrotik"  mac-address : "00:yy:yy:yy:yy:yy" status : "ready"
 
  • Kemudian jalankan prosedur install, tekan tombol browse dan pilih paket routeros-x86-xxx yang sudah didownload sebelumnya
  • Klik tombol install dan tunggu hingga proses selesai.
  • Biasanya akan ada proses partitioning kemudian formating dan dilanjut transfering. (proses Netinstall pada Mikrobits Dinara v3/Ainos v3 memakan waktu cukup lama sekitar 30-40 menit).
  • Setelah status berubah menjadi "waiting reboot" klik tombol "Reboot" pada netinstall dan Mikrobits Dinara v3/Ainos v3 akan reboot.
Pasca Instal ulang netinstall : 
  • Pada saat Dinara atau Ainos reboot tekan lagi tombol "del" untuk masuk ke bios.
  • Setelah masuk bios pilih pada menu "Boot" dan kemudian "Boot Device Priority".
  • Ubah paramater "First Boot Device" yang sebelumnya "[Network: IBA GE Slot]" menjadi "[HDD : PM-InnoDisk]".
  • Tekan tombol keyboard "esc" untuk keluar dari "Boot".
  • Setelah kembali ke menu utama pilih "Save & Exit Setup".
Setelah proses Netinstall selesai di lakukan, biasanya urutan pada interface list akan teracak/tidak sesuai, dan status interface akan Running (R) semua. Untuk solusinya maka Anda bisa lakukan restore terhadap file backup bawaan yang memiliki format dengan kombinasi Serial Number perangkat.

 

Jika file backup bawaan pada Mikrobits Dinara v3/Ainos v3 tidak dapat digunakan, maka opsi lain adalah dengan melakukan inject patch Mikrobits.dpk. Untuk mendapatkan file ini, maka Anda bisa mengirimkan pertanyaan ke Halaman Layanan Pelanggan Citraweb, sertakan serial number perangkat atau software id. 

Note : Patch Mikrobits.dpk dapat digunakan untuk Router OS yang memiliki versi diatas 6.47. 

Artikel ini dibuat pada Tanggal 23 Februari 2021

Sumber: http://mikrotik.co.id/





Belajar Mikrotik: Load Balance dengan Menggunakan Metode PCC (Simple)

Belajar Mikrotik: Load Balance dengan Menggunakan Metode PCC (Simple)

[Load Balance] Load Balance dengan Menggunakan Metode PCC (Simple)



Kebutuhan layanan internet yang sangat besar pada saat ini memungkinkan kita untuk berlangganan lebih dari satu layanan internet. Sebagai administrator/pengelola jaringan, kita harus memastikan koneksi internet yang dimiliki dapat digunakan secara optimal dengan membagi beban dan koneksi ke beberapa jalur/link yang dimiliki dengan menggunakan teknik Load Balance.

Load balance digunakan untuk mendistribusikan beban trafik koneksi pada dua atau lebih jalur koneksi secara seimbang agar trafik berjalan optimal, sehingga dapat memaksimalkan throughput bandwidth yang didapat dari provider. Selain itu laoad balance dapat digunakan untuk memperkecil waktu tanggap dan menghindari overloadpada salah satu jalur koneksi. Ada beberapa metode load balance yang bisa kita gunakan, diantaranya ECMP (Equal-Cost Multiple Path)PCC (Per-Connection Classifier) dan NTH.

PCC (Per-Connection Classifier) mengambil bidang yang dipilih dari header IP, kemudian dengan bantuan algoritma hashing mengubah bidang tersebut menjadi 32-bit. Nilai ini kemudian dibagi dengan denominator tertentu dan sisanya kemudian dibandingkan dengan reminder tertentu, apabila sama maka paket akan ditangkap. Rules dapat dibuat dengan memilih informasi dari src-addressdst-addresssrc-port atau dst-port dari header IP.

PCC merupakan metode yang menspesifikasikan suatu paket menuju gateway koneksi tertentu. PCC mengelompokkan trafik koneksi yang akan melalui atau keluar masuk router menjadi beberapa kelompok. Mikrotik akan mengingat-ingat gateway yang telah dilewati di awal trafik koneksi, sehingga pada paket-paket data selanjutnya yang masih berkaitan dengan paket data sebelumnya akan dilewatkan pada jalur gateway yang sama.

KONFIGURASI DASAR 
Topologi yang akan digunakan adalah sebagai berikut.

 

IP Address 
Router memiliki dua jalur WAN (ISP) dengan alamat IP statis 10.111.0.2/24 (ISP-1) dan alamat IP dinamis 172.16.0.0/24 (ISP-2), sedangkan jaringan lokal menggunakan network 192.168.0.0/24.

/ ip address 
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=ether5 
add address=10.111.0.2/24 network=10.111.0.0 broadcast=10.111.0.255 interface=ether1 

/ip dhcp-client add interface=ether2 add-default-route=no disabled=no

   

NAT 
Untuk konfigurasi NAT, karena terdapat dua uplink ke ISP, maka tambahkan dua rule src-nat mengarah ke ISP masing-masing. 

/ ip firewall nat 
add chain=srcnat out-interface=ether1 action=masquerade comment=nat-isp1 
add chain=srcnat out-interface=ether2 action=masquerade comment=nat-isp2 

 

Policy Routing 
Langkah pertama, untuk mengelola koneksi yang dimulai dari luar, koneksi replies harus keluar melalui interface yang sama (dari IP Publik yang sama) saat koneksi request datang. Lakukan marking untuk menandai semua koneksi masuk, untuk mengingat interface yang digunakan.

/ ip firewall mangle 
add chain=prerouting dst-address=10.111.0.0/24  action=accept in-interface=ether5 
add chain=prerouting dst-address=172.16.0.0/24  action=accept in-interface=ether5 

add chain=prerouting in-interface=ether1 connection-mark=no-mark action=mark-connection new-connection-mark=ISP1_conn 
add chain=prerouting in-interface=ether2 connection-mark=no-mark action=mark-connection new-connection-mark=ISP2_conn

Action mark-routing hanya dapat digunakan di mangle chain output dan prerouting, tetapi mangle chain prerouting menangkap semua lalu lintas yang menuju ke router. Untuk menghindari ini kita akan menggunakan dst-address-type =!local. Selanjutnya tambahkan rule PCC untuk membagi lalu lintas menjadi dua kelompok berdasarkan source address dan destination address (both-addresses). Karena kecepatan koneksi kedua ISP berbeda (1 Mbps dan 512 kbps), kita membagi beban trafiknya menjadi 3 (tiga) bagian. Dua bagian pertama akan melewati gateway ISP-1, dan 1 bagian terakhir akan melewati gateway ISP-2.

/ ip firewall mangle 
add chain=prerouting  in-interface=ether5 connection-mark=no-mark dst-address-type=!local 
    per-connection-classifier=both-addresses:3/0 action=mark-connection new-connection-mark=ISP1_conn 
add chain=prerouting  in-interface=ether5 connection-mark=no-mark dst-address-type=!local 
    per-connection-classifier=both-addresses:3/1 action=mark-connection new-connection-mark=ISP1_conn 
add chain=prerouting  in-interface=ether5 connection-mark=no-mark dst-address-type=!local 
    per-connection-classifier=both-addresses:3/2 action=mark-connection new-connection-mark=ISP2_conn

Setelah rule PCC dibuat, tambahkan action mark-routing berdasarkan connection -mark yang sudah dibuat. Karena policy routing hanya diperlukan untuk trafik yang keluar/menuju ke internet, jangan lupa untuk menentukan parameter in-interface.

/ ip firewall mangle 
add chain=prerouting connection-mark=ISP1_conn in-interface=ether5 action=mark-routing 
    new-routing-mark=to_ISP1 
add chain=prerouting connection-mark=ISP2_conn in-interface=ether5 action=mark-routing 
    new-routing-mark=to_ISP2 

add chain=output connection-mark=ISP1_conn action=mark-routing new-routing-mark=to_ISP1      
add chain=output connection-mark=ISP2_conn action=mark-routing new-routing-mark=to_ISP2

Berikut adalah contoh pembuatan marking load balance PCC pada firewall mangle. 

 

Konfigurasi ini bisa disesuaikan dengan jumlah uplink yang dimiliki, dan juga jumlah jaringan lokal yang saat ini terpasang. 
Setelah konfigurasi mark-connection dan mark-routing selesai, tambahkan rule default route  pada menu IP>Route, yaitu berdasarkan mark-routing yang sudah dibuat. 
Berikut contoh command line yang digunakan.

/ ip route 
add dst-address=0.0.0.0/0 gateway=10.111.0.1 routing-mark=to_ISP1 check-gateway=ping 
add dst-address=0.0.0.0/0 gateway=172.16.0.1 routing-mark=to_ISP2 check-gateway=ping

Tambahkan juga rule berikut ini, yang bisa berfungsi sebagai failover saat salah satu ISP mati atau putus. 

/ ip route 
add dst-address=0.0.0.0/0 gateway=10.111.0.1 distance=1 check-gateway=ping 
add dst-address=0.0.0.0/0 gateway=172.16.0.1 distance=2 check-gateway=ping

 

PENGUJIAN 
Kita melakukan beberapa pengujian untuk membuktikan konfigurasi PCC sudah berjalan dengan baik.

Pengujian Download 
 
Dari hasil pengujian di atas, pada saat mendownload file pertama (1 koneksi) mendapatkan speed 107 KBps/856 kbps yang melalui ISP-1, lalu melakukan download file lagi (koneksi baru) pada server lain mendapatkan speed 59 KBps/472 kbps yang melalui ISP-2.

Pengujian Akses Video 
 
Dari hasil pengujian di atas, ketika mengakses video di website yang berbeda terlihat kedua jalur ISP aktif bersamaan. Dapat dilihat pada trafik kedua interface upstream (ISP), Rx. Rate 1015 kbps dan 525 kbps sesuai dengan kecepatan koneksi masing-masing ISP.

Pengujian Traceroute 
 
Dari hasil kedua traceroute di atas untuk tujuan alamat IP yang berbeda, terlihat keduanya melalui gateway ISP yang berbeda. Tujuan 202.65.113.16 melalui gateway ISP-1 (10.111.0.1) sementara tujuan 103.255.15.28 melalui gateway ISP-2 (172.16.0.1).

Artikel ini disusun pada tanggal 18 Desember 2020 

Sumber: https://citraweb.com

Belajar Mikrotik: [TELTONIKA] Pin Input Output Pada RUT955

Belajar Mikrotik: [TELTONIKA] Pin Input Output Pada RUT955

[TELTONIKA] Pin Input Output Pada RUT955




Input dan Output digunakan untuk memantau dan mengendalikan perangkat yang terhubung atau menerima sinyal dari perangkat itu untuk memicu peristiwa tertentu.
Pada Teltonika RUT955 ini terdapat fitur yang keren yaitu pin input output. Memungkinkan Anda untuk menggunakan RUT955 ini untuk IoT atau hal lain yang menggunakan pin I/O. 
Status

Anda dapat melihat status pin I/O pada menu Service → Input/Output → Status 
Pada menu status ini Anda dapat melihat type, pin, dan status pada pin I/O yang terkait.

 

Pin I/O yang tersedia adalah: 

  1. Digital input, biasa digunakan oleh sensor digital
  2. Digital galvanically isolated input, biasa digunakan oleh sensor digital
  3. Galvanically isolated open collector output & OC output, biasa digunakan untuk relay
  4. Relay output, relay dengan tegangan maksimal 24vdc / 40vac. bisa dikombinasikan dengan relay eksternal jika ingin menggunakan spek diatasnya.
  5. Ground digunakan masing masing ground sesuai dengan spek di gambar.
Custom label 
Kita bisa membuat custom label agar lebih mudah dan nyaman untuk membaca status pin I/O. 
Caranya adalah dengan klik "edit"
 
Digital input name = nama untuk tipe pin input 
High level state name = nama ketika high 
Low level state name = nama ketika low 

Hasil pengeditan custom label adalah seperti berikut:
 
Input
Memungkinkan Anda mengatur parameter input dan menentukan tindakan apa yang harus diambil setelah terpicu. 

Di Teltonika RUT955 terdapat digital input dan analog input. Digital input digunakan oleh sensor digital yang hanya mempunyai logika 0 dan 1. 
Untuk analog input digunakan oleh sensor analog yang menghasilkan output berkelanjutan dan biasanya untuk mengukur sesuatu, misalnya sensor kelebaban atau sensor rintik hujan.

Sebagai contoh kami menggunakan Analog Input untuk percobaan, ketika analog input mendapat sinyal tegangan masuk di antara 1v sampai 2v maka akan mengirim sms dengan teks tertentu ke nomor tertentu. sensor yang kami gunakan adalah modul sensor rintik hujan.
Interval [sec] = Interval waktu si teltonika mengecek I/O 
Input type = Analog 
Alalog type = Analog Voltage 
Trigger = Inside range 
Action = Send SMS 
Enable = Yes 
Input type = Analog 
Analog type = Voltage 
Min [V] = 1 
Max [V] = 2 
Trigger = Inside range 
Action = Send SMS 
SMS text = pesan yang akan disampaikan ketika terpicu. 
Receipient = Single number / user group 
Receipient�s phone number = nomor penerima SMS 

Karena ketika sensor tidak mendeteksi adanya air maka tegangan 5v dan ketika ada pemicu (air) tegangan akan turun, maka saya akan set tegangan rendah untuk mengirim sms.

Wiring nya adalah seperti berikut:
Ketika sensor kering maka analog input akan membaca � 5v karena jenis sensor yang saya gunakan menggunakan tegangan 5v
namun ketika sensor basah, tegangan akan turun sesuai dengan kebasahan yang diterima si sensor, semakin basah semakin turun.
Karena tadi kita mengeset pemicu ketika tegangan di antara 1v sampai 2v akan mengirim sms.
Output
Konfigurasi output memungkinkan Anda untuk mengatur status dari pin output. Di RUT955 terdapat relay output dan galvalically isolated open collector output.
Di pengaturan output configuration ada dua output yang bisa digunakan, yaitu OC output dan Relay Output.
ON/OFF
Anda bisa mengatur secara manual apakah Low adatu High, kemudian bisa juga mengatur ON atau OFF pada tab ON/OFF.
HTTP Post/Get
Pada Tab Post/Get Configuration Anda bisa mengatur username dan password yang nantinya digunakan untuk HTTP POST/GET.
Format HTTP Get adalah sebagai berikut: 

  1. Menyalakan relay output = http://192.168.1.1/cgi-bin/output?username=user1&password=user1&action=on&pin=relay
  2. Menyalakan relay output setelah jeda 10 detik = http://192.168.1.1/cgi-bin/output?username=user1&password=user1&action=on&pin=relay&delay=10
  3. Menyalakan relay output untuk 5 detik = http://192.168.1.1/cgi-bin/output?username=user1&password=user1&action=on&pin=relay&time=5
  4. Menyalakan relay output untuk 5 detik setelah jeda 15 detik = http://192.168.1.1/cgi-bin/output?username=user1&password=user1&action=on&pin=relay&delay=15&time=5
  5. Mematikan relay output untuk 5 detik setelah jeda 15 detik = http://192.168.1.1/cgi-bin/output?username=user1&password=user1&action=off&pin=relay&delay=15&time=5
  6. Menyalakan open collector output = http://192.168.1.1/cgi-bin/output?username=user1&password=user1&action=on&pin=oc
  7. Mematikan open collector output = http://192.168.1.1/cgi-bin/output?username=user1&password=user1&action=off&pin=oc
  8. Menyalakan Digital 4 PIN output = http://192.168.1.1/cgi-bin/output?username=user1&password=user1&action=on&pin=4pin
  9. Mematikan Digital 4 PIN output = http://192.168.1.1/cgi-bin/output?username=user1&password=user1&action=off&pin=4pin
192.168.1.1 bisa diganti dengan ip teltonika yang kalian gunakan. 

Untuk fitur HTTP Post/Get ini bisa dikombinasikan dengan fitur SMS Gateway - SMS Forwarding to HTTP Post/Get. Dengan pengaturan seperti ini:
Enable = Yes 
Method = Get 
Url = http://127.0.0.1/cgi-bin/output 
Number value name = Sender 
Message value name = username

Url merupakan sebagian url dari HTTP Get di I/O, kemudian Number value name sebenarnya tidak dibutuhkan namun perlu diisi untuk bisa bekerja dengan baik. untuk Message value name adalah username. untuk pesan SMS yang dikirimkan adalah seperti ini:
maka kita mendapat format url sebagai berikut: 
http://127.0.0.1/cgi-bin/output?Sender=081234567890&username=user1&password=user1&action=on&pin=relay&time=20 
Sesuai dengan format HTTP Post/Get di atas maka pin relay akan aktif 20 detik.

Periodic Control
Periodic Control digunakan untuk mengatur output dengan waktu tertentu atau interval waktu tertentu. 
Sebagai contoh kita ingin menyalakan dan mematikan relay setiap 1 menit, maka pengaturan nya seperti ini:
Enable = Yes 
Output = Digital relay output 
Action = On 
Action timeout = Yes 
Timeout (sec) = 60 
Mode = Interval 
Interval = 1 min 
Days = All
Output bisa disesuaikan apakah ingin menggunakan relay output atau oc output. Action timeout digunakan untuk menghentikan tindakan yang dilakukan, karena tadi action = on, jika on nya timeout maka kembali ke off lagi. Mode ada interval dan fixed, jika fixed ditentukan waktu.

Scheduler
Scheduler digunakan untuk menjadwal pin output. 
Sebagai contoh pada gambar dibawah bahwa pukul 10-11 relay output akan menyala. 
Command line
Selain melalui webui, Anda juga bisa melihat status dan mengontrol perangkat melalui command line dengan format "gpio.sh <ACTION> <NAME>�" 

root@Teltonika-RUT955:~# gpio.sh 
GPIO control aplication 
        Usage: /sbin/gpio.sh <ACTION> <NAME> 
        ACTION - set, clear, get, export, invert, dirout, dirin, getpin 
        NAME - SIM        DOUT1        DOUT2        DIN1        DIN2        MON        MRST        SDCS        RS485_R 
Keterangan: 
DOUT1 - Digital OC output 
DOUT2 - Digital relay output 
DIN1 - Digital input 
DIN2 - Digital galvanically isolated input

Status
Sebagai contoh kita akan melihat status pin oc output, maka 

root@Teltonika:~# gpio.sh get DOUT1 


arti 0 disini berarti pin dalam keadaan low level

Mengubah Status
Kita bisa juga mengubah status pin output menggunakan command invert, contoh: 

root@Teltonika:~# gpio.sh invert DOUT1 

Selajutnya cek kembali apakah sudah berhasil. 

root@Teltonika:~# gpio.sh get DOUT1 
1

Membaca Analog Input
root@Teltonika:~# cat /sys/class/hwmon/hwmon0/device/in0_input

Platform IoT pihak ketiga
Karena Teltonika RUT955 menggunakan sistem operasi openwrt linux, tentu saja kita bisa menggunakan aplikasi tambahan. 

Teltonika pun sudah menyiapkan beberapa paket untuk terhubung ke platform IoT seperti cumulocity, azure, telenor, dan thingworx.
Sebagai alternatif, teltonika RUT pun juga bisa menggunakan platform IoT yang tidak disebutkan di atas, 
sebagai contoh disini, kami menggunakan platform blynk untuk IoT sederhana. Untuk informasi lebih lengkap Anda bisa mencari nya di internet.
Referensi 
Untuk informasi lebih detail Anda bisa melihat pada halaman wiki teltonika: 
  1. https://wiki.teltonika-networks.com/view/RUT955_Input/Output
Contoh pengaplikasian: 
  1. https://wiki.teltonika-networks.com/view/RUT955_Connecting_relay_to_open_collector_output
  2. https://wiki.teltonika-networks.com/view/Inverting_RUT955_relay_output_polarity
  3. https://wiki.teltonika-networks.com/view/Using_RUT955_Inputs_for_security_applications
  4. https://wiki.teltonika-networks.com/view/Current_measurement_with_RUT955_analog_input
Blynk Openwrt: 
  1. https://www.hackster.io/vshymanskyy/android-ios-app-to-access-your-openwrt-router-remotely-6c23c2
  2. https://github.com/vshymanskyy/blynk-library-lua
==
by: Man (Tech. Support Officer

Sumber: https://citraweb.com/
Belajar Mikrotik: [DHCP Security] - Pencegahan DHCP Rogue dengan DHCP Snooping

Belajar Mikrotik: [DHCP Security] - Pencegahan DHCP Rogue dengan DHCP Snooping

[DHCP Security] - Pencegahan DHCP Rogue dengan DHCP Snooping


Dynamic Host Configuration Protocol atau biasa disebut dengan DHCP. DHCP adalah salah satu fitur pada RouterOS Mikrotik yang terdiri dari 2 bagian, yaitu DHCP Server dan DHCP Client. DHCP Server biasa digunakan untuk mendistribusikan konfigurasi jaringan ke client secara otomatis. Misal seperti IP Address, Netmask, Gateway, DNS, dll.  Penggunaan DHCP dimaksudkan agar user atau administrator tidak perlu melakukan pengaturan pengalamatan jaringan pada client secara manual. 
Pada artikel sebelumnya pernah dibahas Pencegahan DHCP Rogue dengan Bridge Filter(https://citraweb.com/artikel_lihat.php?id=252). Pada artikel kali ini akan membahas metode lain untuk mencegah DHCP Rogue dengan memanfaatkan fitur DHCP Snooping pada Mikrotik.

Rogue DHCP Server adalah salah satu pemanfaatan celah keamanan pada mekanisme konfigurasi alamat jaringan menggunakan DHCP. Rogue DHCP Server memberikan konfigurasi alamat jaringan yang salah kepada client yang tergabung di dalam jaringan dengan tujuan menciptakan serangan jaringan berupa man in the middle, sehingga dapat menimbulkan ancaman terhadap privasi client yang tergabung di dalam jaringan.

Mulai dari RouterOS versi 6.43, mikrotik mengeluarkan fitur baru yaitu DHCP Snooping. DHCP Snooping adalah fitur keamanan Layer 2, yang digunakan untuk membatasi DHCP Server yang tidak sah atau tidak dikenali untuk memberikan informasi berbahaya kepada client. DHCP Snooping bisa diimplementasikan pada Bridge Mikrotik, baik pada perangkat RouterBoard atau perangkat switch seperti Cloud Router Series. 
Di RouterOS Anda dapat menentukan port bridge mana yang Trusted (dipercaya)  dan yang Untrusted (tidak dipercaya). Trusted digunakan untuk menentukan dimana DHCP Server asli berada dan kemana informasi DHCP diteruskan. Jika terdapat DHCP Server pada port Untrusted, maka DHCP Server tersebut akan diabaikan. 
DHCP Option 82 adalah informasi tambahan (Agent Circuit ID dan Agent Remote ID) yang disediakan oleh perangkat DHCP Snooping yang memungkinkan mengidentifikasi perangkat itu sendiri dan client DHCP. 

Simulasi yang dirancang menggunakan 2 buah router dan 1 perangkat switch. Router 1 akan digunakan sebagai DHCP Server asli dan akan terkoneksi di ether2 switch. Sementara itu Router 2 sebagai DHCP Rogue atau DHCP Pengganggu akan terkoneksi ke switch dengan port random (acak). Detail topologi jaringannya adalah sebagai berikut. 
  
DHCP Server dan Rogue DHCP Server pada skenario kali ini sudah dikonfigurasi untuk memberikan alamat IP 192.168.99.0/24 (DHCP Server) dan 192.168.100.0/24 (Rogue DHCP Server), sedangkan semua port dalam switch sudah dimasukkan ke dalam interface bridge. Apabila DHCP Snooping tidak diaktifkan, maka client dimungkinkan akan mendapatkan konfigurasi IP dari salah satu DHCP Server, termasuk Rogue DHCP Server yang Untrusted
Untuk memastikan IP address yang didapat adalah DHCP Server asli, pada Command Prompt (Windows) bisa menggunakan perintah ipconfig /release untuk melepaskan konfigurasi IP Address yang digunakan serta ipconfig /renew untuk melakukan permintaan konfigurasi IP Address baru kepada DHCP Server. 

  
Pada kasus pertama sebelum DHCP Snooping diaktifkan, maka client akan mendapatkan IP Address dari DHCP Server secara random. Client bisa mendapatkan IP dari DHCP asli atau bisa juga mendapatkan IP dari DHCP Rogue. Untuk menanggulangi itu, kita bisa mengaktifkan DHCP Snooping dan DHCP Option 82 pada switch. Langkah yang bisa dilakukan adalah sebagai berikut.
  1. Masuk ke menu Bridge-Port, klik dua kali pada port eth2 yang terhubung ke DHCP Server asli. Beri tanda check pada pilihan Trusted, klik Apply/OK.

     
      
    Pastikan hanya interface yang mengarah ke DHCP Server asli yang status Trusted-nya yes

     
      
  1. Pada menu Bridge, tab-menu Bridge, buka bridge interface ethernet yang sudah dibuat. Beri tanda checkpada DHCP Snooping dan Add DHCP Option 82, kemudian klik Apply/OK, atau dengan mengetikkan perintah berikut pada Terminal.
  2. /interface bridge set [find where name="bridge"] dhcp-snooping=yes add-dhcp-option82=yes 
     

Hasilnya, client hanya akan mendapatkan IP Address dari DHCP Server asli saja. Jika terdapat DHCP Server lain yang terkoneksi ke interface selain ether2, maka DHCP Server tersebut akan diabaikan.
DHCP Snooping ini bisa jadi solusi keamanan DHCP Server agar tidak ada DHCP lain dalam jaringan. Client hanya akan mendapatkan konfigurasi IP dari interface yang dipercaya (Trusted). 

Referensi :


Artikel ini dibuat pada 29 Mei 2020 dengan menggunakan RouterOS versi 6.45. 

Sumber: https://citraweb.com